Exchange Hybrid Wizard Returns an MRS Proxy Server Error

After installing Exchange 2016 and properly configured the URLs, I proceeded to run the Hybrid Configuration Wizard via Office365 portal to find an MRS Proxy error.

MRS Proxy Error

To solve this problem, I took the following steps:

  1. Open the Exchange Management Shell.
  2. Run the following command
Get-WebServicesVirtualDirectory "ServerName\EWS (Default Web Site)" |FL Server,MRSProxyEnabled

If “MRSProxyEnabled :False” is returned in the output, this is the cause of the issue.

However, in my case the results where different. The command returned“MRSProxyEnabled :Enabled”. There is an issue on the hybrid server in which MRSProxy shows as Enabled when you run the Get-WebServicesVirtualDirectory cmdlet, but MRSProxy is actually disabled.

SOLUTION: To solve this issue, users will have to Disable the MRSProxy, restart the IIS services, and Re-Enable the MRSProxy

Set-WebServicesVirtualDirectory "<ServerName>\EWS (Default Web Site)" -MRSProxyEnabled $false
IISReset
Set-WebServicesVirtualDirectory "<ServerName>\EWS (Default Web Site)" -MRSProxyEnabled $true
IISReset
Advertisements

Feel Free to Leave a Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s